Re: [PATCH] sched/doc: Fix stale em_pd_energy() reference in sched-energy

From: Jonathan Corbet

Date: Fri Jul 10 2026 - 15:14:28 EST


luoliang@xxxxxxxxxx writes:

> From: Liang Luo <luoliang@xxxxxxxxxx>
>
> The scheduler energy-aware placement documentation refers to the
> em_pd_energy() API, which was renamed to em_cpu_energy() in commit
> f0b5694791ce ("PM / EM: change name of em_pd_energy to em_cpu_energy").
> Update the reference to the current name.
>
> em_cpu_energy() is the EM helper that compute_energy() in
> kernel/sched/fair.c calls to estimate a performance domain's energy
> consumption (defined in include/linux/energy_model.h).
>
> Sync the zh_CN translation, which carries the same stale name.
>
> Signed-off-by: Liang Luo <luoliang@xxxxxxxxxx>
> ---
> Documentation/scheduler/sched-energy.rst | 2 +-
> Documentation/translations/zh_CN/scheduler/sched-energy.rst | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)

Applied, thanks.

jon