Re: [PATCH] mm/mm_slot.h: add a helper function mm_slot_remove
From: Lorenzo Stoakes
Date: Sat Jul 11 2026 - 02:37:46 EST
On Sat, Jul 11, 2026 at 05:30:41AM +0100, Matthew Wilcox wrote:
> On Fri, Jul 10, 2026 at 01:17:37PM +0100, Lorenzo Stoakes wrote:
> > In general it's fine but I want more :) see below.
>
> ... and these functions all need kernel-doc.
> Not sure where to suggest that it be added to the Documentation/
> Thoughts?
Well could just send out to the KSM/THP people? If somebody has some bandwidth
for it.
Or... are you volunteering yourself? ;)
It'd be unfair to ask Xu to also add kdoc I think, perhaps do that as a
follow-up?
Just need to get those nasty pointless (AFAICT) macros gone.
Cheers, Lorenzo