Re: [PATCH v8 08/10] rust: binder: use `LocalModule` for `THIS_MODULE`

From: Alice Ryhl

Date: Mon Jul 13 2026 - 04:22:10 EST


On Mon, Jul 13, 2026 at 02:45:29PM +0800, Alvin Sun wrote:
> Replace the `THIS_MODULE` static reference in the binder fops with
> `this_module::<LocalModule>()`, consistent with the move of
> `THIS_MODULE` into the `ModuleMetadata` trait.
>
> Assisted-by: opencode:glm-5.2
> Reviewed-by: Gary Guo <gary@xxxxxxxxxxx>
> Acked-by: Danilo Krummrich <dakr@xxxxxxxxxx>
> Signed-off-by: Alvin Sun <alvin.sun@xxxxxxxxx>

Most other Rust Binder commits use 'rust_binder:' prefix rather than
'rust: binder:'.

Alice