Re: [PATCH v5 04/18] iommu: Convert gdev->blocked from bool to enum gdev_blocked

From: Nicolin Chen

Date: Mon Jul 13 2026 - 14:28:01 EST


On Mon, Jul 13, 2026 at 07:33:51PM +0800, Baolu Lu wrote:
> On 7/3/2026 12:06 PM, Nicolin Chen wrote:
> > +enum gdev_blocked {
> > + BLOCKED_NO = 0, /* Not blocked */
> > + BLOCKED_RESETTING, /* PCI reset in flight */
> > +};
>
> Nit: Would it be more readable if we rename this to 'enum
> blocked_reason'? Something like:
>
> enum blocked_reason {
> BLOCKED_NONE = 0,
> BLOCKED_RESETTING,
> };

That should work for me.

Thanks
Nicolin