[PATCH] ioport: Use kzalloc() instead of kmalloc()/memset() in _sparc_alloc_io()

From: longlong yan

Date: Tue Jul 14 2026 - 05:15:44 EST


Replace kmalloc+memset by kzalloc for better readability and simplicity.
This addresses the warning below:
WARNING: kzalloc should be used for data, instead of kmalloc/memset

Fixes: 1da177e4c3f4 ("Linux-2.6.12-rc2")
Signed-off-by: longlong yan <yanlonglong@xxxxxxxxxx>
---
arch/sparc/kernel/ioport.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/arch/sparc/kernel/ioport.c b/arch/sparc/kernel/ioport.c
index cbc0680a4642..df73439b290c 100644
--- a/arch/sparc/kernel/ioport.c
+++ b/arch/sparc/kernel/ioport.c
@@ -184,9 +184,8 @@ static void __iomem *_sparc_alloc_io(unsigned int busno, unsigned long phys,
printed_full = 1;
}
tlen = strlen(name);
- tack = kmalloc(sizeof (struct resource) + tlen + 1, GFP_KERNEL);
+ tack = kzalloc(sizeof (struct resource) + tlen + 1, GFP_KERNEL);
if (tack == NULL) return NULL;
- memset(tack, 0, sizeof(struct resource));
res = (struct resource *) tack;
tack += sizeof (struct resource);
}
--
2.43.0