Re: [PATCH v4 13/27] KVM: s390: Prepare KVM/s390 for a second KVM module

From: Steffen Eiden

Date: Tue Jul 14 2026 - 06:41:34 EST


On Mon, Jul 13, 2026 at 06:38:29PM +0200, Claudio Imbrenda wrote:
> On Mon, 6 Jul 2026 10:52:13 +0200
> Steffen Eiden <seiden@xxxxxxxxxxxxx> wrote:
>
> > Lay the groundwork for a second KVM module. Guard KVM/s390 behind the
> > KVM_S390 config and turn CONFIG_KVM on if selected. Move all the
> > kvm_host definitions to _s390 postfixed headers. Prepare local header
> > include guards for a new location. Move gamp related tracing into a
> > separate file. While at it, rename the main KVM/s390 files from
> > s390-kvm.{c,h} to just s390.{c,h} to match the naming scheme of other
> > architectures.
> >
> > No functional change.
> >
> > Signed-off-by: Steffen Eiden <seiden@xxxxxxxxxxxxx>
> > ---
> > arch/s390/Kconfig | 2 +-
> > arch/s390/boot/ipl_parm.c | 2 +-
> > arch/s390/boot/uv.c | 2 +-
> > arch/s390/configs/debug_defconfig | 2 +-
> > arch/s390/configs/defconfig | 2 +-
> > arch/s390/include/asm/kvm_host.h | 774 +-----------------
> > .../asm/{kvm_host.h => kvm_host_s390.h} | 6 +-
> > ...kvm_host_types.h => kvm_host_s390_types.h} | 6 +-
>
> I really dislike those "almost renames". I'd prefer to have a prior
> patch with the differences, and a second patch for the move.

I dislike this to. I tried to reduce it to a minimum.
I could prepend a patch that changes the macro guard before this patch.
This is the change in question.

In fact the whole purpose of this patch is to reduce the almost renames
and let the next patch be a pure move ( minus one keeping stuff compile
change)
>
> > arch/s390/include/asm/kvm_host_types.h | 347 +-------
> > arch/s390/kernel/early.c | 2 +-
> > arch/s390/kernel/entry.S | 10 +-
> > arch/s390/kernel/perf_event.c | 2 +-
> > arch/s390/kvm/Kconfig | 10 +-
> > arch/s390/kvm/Makefile | 2 +-
> > arch/s390/kvm/dat.h | 6 +-
> > arch/s390/kvm/diag.c | 2 +-
> > arch/s390/kvm/faultin.c | 3 +-
> > arch/s390/kvm/faultin.h | 6 +-
> > arch/s390/kvm/gaccess.c | 2 +-
> > arch/s390/kvm/gaccess.h | 2 +-
> > arch/s390/kvm/gmap.c | 2 +-
> > arch/s390/kvm/gmap.h | 6 +-
> > arch/s390/kvm/guestdbg.c | 2 +-
> > arch/s390/kvm/intercept.c | 2 +-
> > arch/s390/kvm/interrupt.c | 2 +-
> > arch/s390/kvm/pci.c | 2 +-
> > arch/s390/kvm/priv.c | 2 +-
> > arch/s390/kvm/pv.c | 2 +-
> > arch/s390/kvm/{kvm-s390.c => s390.c} | 2 +-
this almost move is required by the compiler (change header form kvm-s390.h to s390.h)
> > arch/s390/kvm/{kvm-s390.h => s390.h} | 2 +-
this change in theory could be prepended but would leave the comment in
place invalid for one patch.

> > arch/s390/kvm/sigp.c | 2 +-
> > arch/s390/kvm/trace-gmap.h | 45 +
> > arch/s390/kvm/trace.h | 14 -
> > arch/s390/kvm/vsie.c | 2 +-
> > include/linux/kvm_host.h | 2 +-
> > 35 files changed, 103 insertions(+), 1176 deletions(-)
>
> [...]

Steffen