Re: [RFC PATCH 02/34] ARM: mm: make 2-level pgd_t a scalar
From: David Laight
Date: Tue Jul 14 2026 - 08:42:21 EST
On Mon, 13 Jul 2026 14:55:41 +0100
Yeoreum Yun <yeoreum.yun@xxxxxxx> wrote:
> From: "David Hildenbrand (Arm)" <david@xxxxxxxxxx>
>
> We don't want pgd_t to be an array, as it prohibits returning it from a
> function, like pgdp_get().
If you use a two element structure the compiler/ABI might be able to
return that from a function in two registers.
That might make the entire mess more readable ...
David