Re: [PATCH v6 2/9] mm/page_owner: add MR_NEVER to enum migrate_reason and use it for last_migrate_reason

From: David Hildenbrand (Arm)

Date: Tue Jul 14 2026 - 10:49:16 EST


On 7/14/26 15:49, Vlastimil Babka (SUSE) wrote:
> On 7/14/26 15:22, David Hildenbrand (Arm) wrote:
>> On 7/14/26 15:09, Vlastimil Babka (SUSE) wrote:
>>>
>>> It's not used ever as a reason that would be actually passed to migration.
>>
>> Right, it's a placeholder for "there is no migrate reason because it is unset"
>>
>>> So I think the name is more descriptive this way.
>>
>> Not sure I agree. The usual translation of -1 -> unset is NONE or UNSET.
>
> (note it's no longer -1 after the patch.)
>
>> At least I was confused by "NEVER".
>
> I won't bikeshed this, so whatever.

Just to be clear: if everybody here agrees that MR_NEVER is the right thing to
use, fine with me.

I just stumbled over it and it caught my attention.

>
> Just to avoid another extra respin, please also say how the following line
> should change, as if we only rename MR_NEVER to MR_NONE, it will be:
>
> + EMe(MR_NONE, "never_migrated")

I would probably just have use "not set".

And if "last_migrate_reason == MR_NONE" that would imply "never".

Ye Liu, feel free to keep it as is if you agree that using NEVER is better here.


--
Cheers,

David