Re: [PATCH] xfs: use kmalloc_array() instead of kmalloc() in xfs_da_grow_inode_int

From: Darrick J. Wong

Date: Tue Jul 14 2026 - 11:43:02 EST


On Tue, Jul 14, 2026 at 03:17:24AM -0600, Cihan Karadag wrote:
> Replace the open-coded
>
> sizeof(*mapp) * count
>
> multiplication with kmalloc_array(), based on kernel coding guidelines
> against open-coded arithmetic in allocator arguments.
>
> Signed-off-by: Cihan Karadag <cihan.cihan@xxxxxxxxx>
> ---
> fs/xfs/libxfs/xfs_da_btree.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/xfs/libxfs/xfs_da_btree.c b/fs/xfs/libxfs/xfs_da_btree.c
> index 9debb95d86fa0..99e4318ba75f2 100644
> --- a/fs/xfs/libxfs/xfs_da_btree.c
> +++ b/fs/xfs/libxfs/xfs_da_btree.c
> @@ -2354,7 +2354,7 @@ xfs_da_grow_inode_int(
> * If we didn't get it and the block might work if fragmented,
> * try without the CONTIG flag. Loop until we get it all.
> */
> - mapp = kmalloc(sizeof(*mapp) * count,
> + mapp = kmalloc_array(count, sizeof(*mapp),
> GFP_KERNEL | __GFP_NOFAIL);

kmalloc_objs?

--D

> for (b = *bno, mapi = 0; b < *bno + count; ) {
> c = (int)(*bno + count - b);
> --
> 2.54.0
>
>