Re: [PATCH v2 0/7] mm/khugepaged: several cleanups

From: Andrew Morton

Date: Wed Jul 15 2026 - 00:42:06 EST


On Tue, 14 Jul 2026 20:59:29 -0600 Nico Pache <npache@xxxxxxxxxx> wrote:

> The following changes stem from a number of reviews during my khugepaged
> mTHP support series [1]. Some of these are minor code cleanups, issues or
> reviews that we decided to deferred to a followup series, or in the case
> of the more major patch of the series, changes [2] Lance Yang attempted
> while my series was in-flight and we decided to wait till later to try.
>
> The first 3 patches introduce helper functions to increase code reuse and
> readability. This includes a per-scan state clearing function, extracting
> the young page check into a helper, and a count_collapse_event() function
> to reduce a repetative pattern used across mTHP collapse.
>
> The 4th patch was the byproduct of me throwing Claude at all the
> comments in khugepaged verifying and looking for any outdated info.
>
> The 5th patch is based on Lance Yang's commit series [2] trying to extract
> the PTE state checking into a helper function. This required a bit of
> rewriting due to differences after mTHP collapse was introduced. I also
> took into account the changes requested during his patches review cycle.
>
> The remaining 2 patches were review points during my mTHP series that we
> agreed can be deferred to a later series.
>
> Thank you to those whos reviews and work I leveraged to achieve these
> cleanups.

Sashiko seems to have a good point about [5/7]:
https://sashiko.dev/#/patchset/20260715025941.1571316-1-npache@xxxxxxxxxx