Re: [RFC PATCH 01/22] dt-bindings: memory: cdns,k3-ddr: Add Cadence K3 DDR controller binding

From: Krzysztof Kozlowski

Date: Wed Jul 15 2026 - 00:55:54 EST


On 14/07/2026 14:55, MANNURU VENKATESWARLU wrote:
> Add device tree binding for the Cadence DDR controller used in TI K3 SoCs.
>
> Signed-off-by: Neha Malcom Francis <n-francis@xxxxxx>
> Signed-off-by: Gandhar Deshpande <g-deshpande@xxxxxx>
> Signed-off-by: MANNURU VENKATESWARLU <v-mannuru@xxxxxx>
> ---
> .../memory-controllers/ti/cdns,k3-ddr.yaml | 81 +++++++++++++++++++
> 1 file changed, 81 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/memory-controllers/ti/cdns,k3-ddr.yaml
>

Where is the rest of 22 patches? I got only these three patches.


A nit, subject: drop second/last, redundant "bindings". The
"dt-bindings" prefix is already stating that these are bindings.
See also:
https://elixir.bootlin.com/linux/v7.1-rc7/source/Documentation/devicetree/bindings/submitting-patches.rst#L23

> diff --git a/Documentation/devicetree/bindings/memory-controllers/ti/cdns,k3-ddr.yaml b/Documentation/devicetree/bindings/memory-controllers/ti/cdns,k3-ddr.yaml
> new file mode 100644
> index 0000000000000..89caeb111627a
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/memory-controllers/ti/cdns,k3-ddr.yaml
> @@ -0,0 +1,81 @@
> +# SPDX-License-Identifier: GPL-2.0-only OR BSD-2-Clause
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/memory-controllers/ti/cdns,k3-ddr.yaml#
> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Cadence DDR controller for K3 devices
> +
> +maintainers:
> + - Santhosh Kumar K <s-k6@xxxxxx>
> + - Neha Malcom Francis <n-francis@xxxxxx>
> +
> +properties:
> + compatible:
> + const: cdns,k3-ddr

cdns does not make a K3 SoC.

This is confusing. Are you sure you understand which company products
you are working on?


> +
> + reg:
> + minItems: 3

Drop.

> + maxItems: 3
> + description: |
> + Address ranges for the different register regions of the DDRSS controller.
> + - ctl_cfg: Controller configuration registers
> + - ctl_cfg_pi: PHY Interface configuration registers
> + - ctl_cfg_phy: PHY configuration registers

Describe items.

> +
> + reg-names:
> + items:
> + - const: ctl_cfg
> + - const: ctl_cfg_pi
> + - const: ctl_cfg_phy
> +
> + bootph-pre-ram: true

Nope

> +
> +required:
> + - compatible
> + - reg
> + - reg-names
> +
> +unevaluatedProperties: false

More NO.

Really, can't you make some internal review back there in TI to avoid
sending something which does not resemble upstream code at all?

> +
> +examples:
> + - |
> + #include <dt-bindings/interrupt-controller/arm-gic.h>
> + #include <dt-bindings/soc/ti,sci_pm_domain.h>
> +
> + cbass_main {

NAK

> + #address-cells = <2>;
> + #size-cells = <2>;
> +
> + memorycontroller: memorycontroller@2980000 {


git grep memorycontroller

And it did not made you thinking that name is wrong? I am done with it.


> + compatible = "ti,j721e-ddrss";

Irrelevant. Which binding are you describing here?

Best regards,
Krzysztof