Re: [PATCH] x86/atomic: Add arch_atomic_not()

From: Gary Guo

Date: Wed Jul 15 2026 - 07:50:30 EST


On Tue Jul 14, 2026 at 6:42 AM BST, Ziran Zhang wrote:
> The kernel already has non-atomic bitmap_complement(), but
> no direct atomic implementation.
>
> According to Intel and AMD manuals, the NOT instruction
> supports a LOCK prefix.
>
> Currently the only way to achieve this is arch_atomic_xor(-1, v),
> which is non-obvious and hurts readability, so add arch_atomic_not()
> to provide an explicit atomic complement operation.

What do you need this for?

Best,
Gary

>
> Signed-off-by: Ziran Zhang <zhangcoder@xxxxxxxx>
> ---
> arch/x86/include/asm/atomic.h | 7 +++++++
> 1 file changed, 7 insertions(+)
>
> diff --git a/arch/x86/include/asm/atomic.h b/arch/x86/include/asm/atomic.h
> index 75743f1df..d7e543194 100644
> --- a/arch/x86/include/asm/atomic.h
> +++ b/arch/x86/include/asm/atomic.h
> @@ -168,6 +168,13 @@ static __always_inline int arch_atomic_fetch_xor(int i, atomic_t *v)
> }
> #define arch_atomic_fetch_xor arch_atomic_fetch_xor
>
> +static __always_inline void arch_atomic_not(atomic_t *v)
> +{
> + asm_inline volatile(LOCK_PREFIX "notl %0"
> + : "+m" (v->counter) :: "memory");
> +}
> +#define arch_atomic_not arch_atomic_not
> +
> #ifdef CONFIG_X86_32
> # include <asm/atomic64_32.h>
> #else