Re: [PATCH v2] ata: use named initializers for acpi_device_id

From: Niklas Cassel

Date: Tue Aug 04 2026 - 05:59:35 EST


On Tue, Aug 04, 2026 at 10:44:26AM +0100, Pawel Zalewski via B4 Relay wrote:
> From: "Pawel Zalewski (The Capable Hub)" <pzalewski@xxxxxxxxxxxxxxxxxxxx>
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base. Also
> drop explicitly setting fields to 0 where it is redundant.
>
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>

Reviewed-by: Niklas Cassel <cassel@xxxxxxxxxx>