Re: [PATCH v2] ata: use named initializers for acpi_device_id

From: Damien Le Moal

Date: Tue Aug 04 2026 - 06:05:26 EST


On 8/4/26 18:44, Pawel Zalewski via B4 Relay wrote:
> From: "Pawel Zalewski (The Capable Hub)" <pzalewski@xxxxxxxxxxxxxxxxxxxx>
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base. Also
> drop explicitly setting fields to 0 where it is redundant.
>
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>

Applied to for-7.3. Thanks!

--
Damien Le Moal
Western Digital Research