Re: [PATCH 6/6] mm/swap: rename __swap_writepage() to __swap_writeout()

From: Matthew Wilcox

Date: Fri Aug 07 2026 - 18:32:02 EST


On Thu, Aug 06, 2026 at 06:55:38PM -0400, Tal Zussman wrote:
> Commit 84798514db50 ("mm: Remove swap_writepage() and
> shmem_writepage()") renamed swap_writepage() to swap_writeout(). Rename
> __swap_writepage(), which operates on a folio, to match its caller.
> Update a stale reference to swap_writepage() in swapfile.c as well.
>
> Signed-off-by: Tal Zussman <tz2294@xxxxxxxxxxxx>

Reviewed-by: Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx>