Re: [PATCH v2 4/8] KVM: VMX: Rename posted interrupt prefixes from "vmx" to "vt"
From: Xiaoyao Li
Date: Thu Aug 27 2026 - 07:38:31 EST
On 8/27/2026 1:12 AM, Sean Christopherson wrote:
Rename all common posted interrupt APIs that use a "vmx" prefix to instead
use a "vt" prefix to capture that they are used for both VMX and TDX vCPUs.
No functional change intended.
Signed-off-by: Sean Christopherson <seanjc@xxxxxxxxxx>
With renaming vmx_needs_pi_wakeup() to vt_needs_pi_wakeup(),
Reviewed-by: Xiaoyao Li <xiaoyao.li@xxxxxxxxx>
---
arch/x86/kvm/vmx/common.h | 4 ++--
arch/x86/kvm/vmx/main.c | 4 ++--
arch/x86/kvm/vmx/posted_intr.c | 18 +++++++++---------
arch/x86/kvm/vmx/posted_intr.h | 8 ++++----
arch/x86/kvm/vmx/tdx.c | 6 +++---
arch/x86/kvm/vmx/vmx.c | 6 +++---
6 files changed, 23 insertions(+), 23 deletions(-)
diff --git a/arch/x86/kvm/vmx/common.h b/arch/x86/kvm/vmx/common.h
index 4b1d46eafd0f..ff4f6a2b6402 100644
--- a/arch/x86/kvm/vmx/common.h
+++ b/arch/x86/kvm/vmx/common.h
@@ -170,8 +170,8 @@ static inline void kvm_vcpu_trigger_posted_interrupt(struct kvm_vcpu *vcpu,
* Post an interrupt to a vCPU's PIR and trigger the vCPU to process the
* interrupt if necessary.
*/
-static inline void __vmx_deliver_posted_interrupt(struct kvm_vcpu *vcpu,
- struct pi_desc *pi_desc, int vector)
+static inline void __vt_deliver_posted_interrupt(struct kvm_vcpu *vcpu,
+ struct pi_desc *pi_desc, int vector)
Nit: Maybe we can just name it vt_deliver_posted_interrupt() without underscore since no collide with vmx_deliver_posted_interrupt() anymore?
But it's OK to keep the underscore to indicate it's an common inner helper.