Re: [PATCH v2 4/8] KVM: VMX: Rename posted interrupt prefixes from "vmx" to "vt"

From: Sean Christopherson

Date: Thu Aug 27 2026 - 10:20:57 EST


On Thu, Aug 27, 2026, Xiaoyao Li wrote:
> On 8/27/2026 1:12 AM, Sean Christopherson wrote:
> > diff --git a/arch/x86/kvm/vmx/common.h b/arch/x86/kvm/vmx/common.h
> > index 4b1d46eafd0f..ff4f6a2b6402 100644
> > --- a/arch/x86/kvm/vmx/common.h
> > +++ b/arch/x86/kvm/vmx/common.h
> > @@ -170,8 +170,8 @@ static inline void kvm_vcpu_trigger_posted_interrupt(struct kvm_vcpu *vcpu,
> > * Post an interrupt to a vCPU's PIR and trigger the vCPU to process the
> > * interrupt if necessary.
> > */
> > -static inline void __vmx_deliver_posted_interrupt(struct kvm_vcpu *vcpu,
> > - struct pi_desc *pi_desc, int vector)
> > +static inline void __vt_deliver_posted_interrupt(struct kvm_vcpu *vcpu,
> > + struct pi_desc *pi_desc, int vector)
>
> Nit: Maybe we can just name it vt_deliver_posted_interrupt() without
> underscore since no collide with vmx_deliver_posted_interrupt() anymore?
>
> But it's OK to keep the underscore to indicate it's an common inner helper.

Yeah, I went through pretty much the exact same sequence of thoughts. I'll keep
the underscores unless someone feels strongly that they do more harm than good.
They're a bit odd, here and in the EPT violation handler, but I do think it helps
communicate/capture that VMX/TDX-specific code needs to run before/after invoking
the inner helper.