Re: [f2fs-dev] [PATCH v8 07/12] f2fs: cache: use node cache

From: Zhiguo Niu

Date: Thu Sep 17 2026 - 01:56:07 EST


Chao Yu <chao@xxxxxxxxxx> 于2026年9月17日周四 10:55写道:
>
> On 9/16/26 17:15, Zhiguo Niu wrote:
> >> static void __submit_merged_write_cond(struct f2fs_sb_info *sbi,
> >> struct inode *inode, struct folio *folio,
> >> - nid_t ino, enum page_type type, bool writeback)
> >> + bool writeback)
> > Hi Chao,
> > seems this function just only handle DATA type now, so can we rename
> > it xxx_data_xxx for easy reading?
>
> Zhiguo,
>
> I rename it to __submit_merged_data_write_cond() for readability.
Hi Chao,
It is good to me.
Thanks!
>
> Thanks,
>