[PATCH 3/4] kconfig: tests: warn_changed_input: Simplify by reusing the extra env
From: Nicolas Schier
Date: Thu Sep 17 2026 - 10:13:05 EST
Define the extra environment once and re-use it for the respective
_run_conf() calls to increase readability.
Signed-off-by: Nicolas Schier <n.schier@xxxxxxxxx>
---
scripts/kconfig/tests/warn_changed_input/__init__.py | 16 +++++++---------
1 file changed, 7 insertions(+), 9 deletions(-)
diff --git a/scripts/kconfig/tests/warn_changed_input/__init__.py b/scripts/kconfig/tests/warn_changed_input/__init__.py
index 4c3bca6af846..a5f07d4a882c 100644
--- a/scripts/kconfig/tests/warn_changed_input/__init__.py
+++ b/scripts/kconfig/tests/warn_changed_input/__init__.py
@@ -8,26 +8,24 @@ KCONFIG_WARN_CHANGED_INPUT is enabled.
def test(conf):
+ warn_changed_input = {
+ "KCONFIG_WARN_CHANGED_INPUT": "1",
+ }
+
assert conf.olddefconfig('config') == 0
assert 'user-provided values changed by Kconfig' not in conf.stderr
assert conf._run_conf('--olddefconfig', dot_config='config',
- extra_env={
- 'KCONFIG_WARN_CHANGED_INPUT': '1',
- }) == 0
+ extra_env=warn_changed_input) == 0
assert conf.stderr_contains('expected_stderr')
assert conf.config_matches('expected_config')
assert conf._run_conf('--olddefconfig', dot_config='config',
- extra_env={
- 'KCONFIG_WARN_CHANGED_INPUT': '1',
- }, silent=True) == 0
+ extra_env=warn_changed_input, silent=True) == 0
assert conf.stderr_contains('expected_stderr')
assert conf._run_conf('--savedefconfig=defconfig', dot_config='config',
out_file='defconfig',
- extra_env={
- 'KCONFIG_WARN_CHANGED_INPUT': '1',
- }) == 0
+ extra_env=warn_changed_input) == 0
assert conf.stderr_contains('expected_stderr')
assert conf.config_matches('expected_defconfig')
--
2.55.0