[PATCH] mtd: cfi_cmdset_0001: use assign_bit() where applicable

From: Peng Fan (OSS)

Date: Sat Sep 19 2026 - 09:10:50 EST


From: Peng Fan <peng.fan@xxxxxxx>

Convert open-coded if/else with set_bit/clear_bit to the assign_bit API.

Signed-off-by: Peng Fan <peng.fan@xxxxxxx>
---
drivers/mtd/chips/cfi_cmdset_0001.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
index 60d82a1acb01..e5805eebeed6 100644
--- a/drivers/mtd/chips/cfi_cmdset_0001.c
+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
@@ -2520,10 +2520,7 @@ static void cfi_intelext_save_locks(struct mtd_info *mtd)

status = cfi_varsize_frob(mtd,
do_getlockstatus_oneblock, adr, len, NULL);
- if (status)
- set_bit(block, region->lockmap);
- else
- clear_bit(block, region->lockmap);
+ assign_bit(block, region->lockmap, status);
}
}
}
--
2.51.0