Re: [RFC PATCH v6 06/11] iommu: Add a helper to query vIOMMU hardware parameters

From: Jason Gunthorpe

Date: Thu Sep 24 2026 - 15:43:09 EST


> [ ... 18 lines skipped ... ]
> +int iommu_viommu_get_params(struct device *dev,
> + enum iommu_viommu_type type, void *params, size_t params_size)
> +{

I imagined this would be a direct function call from TSM to iommu
driver? Is there a reason to do it this way? I think a TSM -> iommu
module dependency is OK

--
Jason