Re: [RFC PATCH v6 06/11] iommu: Add a helper to query vIOMMU hardware parameters

From: Aneesh Kumar K . V

Date: Fri Sep 25 2026 - 02:00:23 EST


Jason Gunthorpe <jgg@xxxxxxxxxx> writes:

>> [ ... 18 lines skipped ... ]
>> +int iommu_viommu_get_params(struct device *dev,
>> + enum iommu_viommu_type type, void *params, size_t params_size)
>> +{
>
> I imagined this would be a direct function call from TSM to iommu
> driver? Is there a reason to do it this way? I think a TSM -> iommu
> module dependency is OK
>

Do you mean that the TSM backend should call arm_smmu_get_realm_params()
directly? I was trying to avoid that dependency. TSM depends only on
iommufd, not on the SMMU driver. Making this part of iommu_ops also
simplifies supporting different get_params implementations for different
hardware IOMMUs on the same architecture, if needed.

-aneesh