Re: [PATCH v12 24/25] x86/resctrl: Simplify Kconfig options for resctrl

From: Reinette Chatre

Date: Thu Sep 24 2026 - 17:00:06 EST


Hi Tony,

On 9/16/26 4:13 PM, Tony Luck wrote:
> Linus Torvalds complained[1] about Kconfig complexity making it too
> hard for "random people to build their own kernels".
>
> CONFIG_X86_CPU_RESCTRL_INTEL_AET has been causing problems since it was first
> added as it required other config options to be set to "built-in". There is
> no longer a requirement that INTEL_PMT_TELEMETRY or INTEL_TPMI be built-in.
>
> Drop CONFIG_X86_CPU_RESCTRL_INTEL_AET and unconditionally include
> AET (Application Energy Telemetry) as part of X86_CPU_RESCTRL.
>
> Link: https://lore.kernel.org/all/CAHk-=whigg3hvOy7c1j1MXFy6o6CHp0g4Tc3Y-MAk+XDssHU0A@xxxxxxxxxxxxxx # [1]
> Signed-off-by: Tony Luck <tony.luck@xxxxxxxxx>

See "Ordering of commit tags" in Documentation/process/maintainer-tip.rst

> diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
> index 5e71dd758624..93d36fa8c638 100644
> --- a/arch/x86/kernel/cpu/resctrl/internal.h
> +++ b/arch/x86/kernel/cpu/resctrl/internal.h
> @@ -233,24 +233,11 @@ bool rdt_cpu_has(int flag);
> void rdt_domain_reconfigure_cdp(struct rdt_resource *r);
> void resctrl_arch_mbm_cntr_assign_set_one(struct rdt_resource *r);
>
> -#ifdef CONFIG_X86_CPU_RESCTRL_INTEL_AET
> bool intel_aet_pre_mount(void);
> void intel_aet_unmount(void);

The function names imply they are Intel only while they will now always run
on all x86. Should the "intel_" be dropped to make this clear so that folks will
hopefully always keep in mind how these functions behave when run on non-Intel
systems that do not support AET?

Reinette