[PATCH 0/5] random crypto cleanups
From: Denis Vlasenko
Date: Mon Jun 20 2005 - 05:57:43 EST
1.be_le.patch:
Introduce {load/store}_{be/le}{32/64}() macros
and use them instead of open-coded conversions.
Introduce BYTEn() macros for extraction of n'th
byte from wider integers and use it.
2.wp.patch:
Fix gcc3.4.3 -O2 whirlpool stack overflow.
3.tf.patch:
Dramatically reduce size of twofish key setup code
with modest increase of key setup time.
4.rot64.patch:
Introduce 64bit rotations (generic + i386 asm),
convert few existing places to use it.
Per previous comments, replace inline -> __inline__
in headers.
z.patch:
use BYTEn() in more places, simplify some tgr192.c bits
Cumulative patch was tested with tcrypt.
Please apply patches 1-4, comment on z.patch.
Patches will be mailed as replies.
--
vda
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/