Re: [PATCH 4/4] Slab Reclaim logic

From: Christoph Lameter
Date: Thu Jun 22 2006 - 15:44:10 EST


On Thu, 22 Jun 2006, Pekka J Enberg wrote:

> Some coding style comments below.
>
> > +extern long kmem_cache_reclaim(struct kmem_cache *, gfp_t flags, unsigned long);
>
> The parameter name is redundant.

Ok.
>
> > +static int try_reclaim_one(kmem_cache_t *cachep, struct kmem_list3 *l3,
> > + struct list_head *list, unsigned short marker)
>
> Please use struct kmem_cache instead of the typedef. Better name for l3
> would be nice.

l3 is a very good name.

> > +{
> > + int nr_freed = 0;
>
> s/nr_freed/ret/

ret is non descriptive. nr_freed is describing what the purpose of the
variable is.

> > + while (nr_freed < slabs_to_free) {
> > + int x;
>
> s/x/nr_freed/

Would shadow variable.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/