Re: lots of code could be simplified by using ARRAY_SIZE()
From: Miguel Ojeda
Date: Thu Dec 14 2006 - 18:16:26 EST
On 12/13/06, Robert P. J. Day <rpjday@xxxxxxxxxxxxxx> wrote:
there are numerous places throughout the source tree that apparently
calculate the size of an array using the construct
"sizeof(fubar)/sizeof(fubar[0])". see for yourself:
$ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" *
but we already have, from "include/linux/kernel.h":
#define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
Maybe *(x) instead of (x)[0]?
--
Miguel Ojeda
http://maxextreme.googlepages.com/index.htm
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/