Re: lots of code could be simplified by using ARRAY_SIZE()

From: Robert P. J. Day
Date: Thu Dec 14 2006 - 19:22:33 EST


On Fri, 15 Dec 2006, Miguel Ojeda wrote:

> On 12/13/06, Robert P. J. Day <rpjday@xxxxxxxxxxxxxx> wrote:
> >
> > there are numerous places throughout the source tree that apparently
> > calculate the size of an array using the construct
> > "sizeof(fubar)/sizeof(fubar[0])". see for yourself:
> >
> > $ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" *
> >
> > but we already have, from "include/linux/kernel.h":
> >
> > #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
>
> Maybe *(x) instead of (x)[0]?

yeah, there's a bunch of that, too:

$ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\*\1\)" .

easy enough to catch using the same technique.

rday
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/