Re: [PATCH 17/20] SMP: Implement on_cpu()
From: Andi Kleen
Date: Mon Jul 09 2007 - 03:16:51 EST
> Well, smp_call_function_single() is arch specific whereas on_cpu() is
Yes, but the few instances should be relatively easy to fix.
> generic code. Perhaps rename smp_call_function_single() to
> __smp_call_function_single() and on_cpu() to smp_call_function_single()?
The low level function checks for this anyways. Instead of erroring
it should just DTRT.
>
> I dislike the loss of symmetry though.
on_each_cpu() was imho always a mistake. It would have been better
to just fix smp_call_function() directly
-Andi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/