Re: [git pull] drm: previous pull req + 1.

From: Andy Lutomirski
Date: Sat Jun 20 2009 - 23:49:40 EST

Dave Airlie wrote:
Hi Linus,

Please pull the 'drm-linus' branch from
ssh:// drm-linus

This is the same tree from the previous pull request + the fix from Pierre that actually makes the PAE/GEM combination on i965 work. \o/

I tried this tree (specifically, a merge of Linus' fb20871 this tree) on Fedora 11 with modesetting enabled on an integrated Radeon 2100, and plymouthd crashes immediately with a corrupt page table. Photo attached. After the crash, bootup stops, although ctrl-alt-del works.

This is on a Gigabyte GA-MA74GM-S2 (RS690 chipset) with a somewhat old BIOS which has never had reliable graphics on X with any kernel and userspace I've tried, modesetting or otherwise, so this isn't a regression per se. But on F11's kernel, I can at least boot to a console with modesetting enabled and nothing dies until I try to start X, and, with modesetting off on older kernels I can boot just fine (again, until I try to use X, at which point things break).

I'd be happy to test things to help debug.


JPEG image