Re: [regression] 2.6.39-rc[1-3] fail to boot on G5 PowerMac

From: Mikael Pettersson
Date: Wed Apr 13 2011 - 04:16:52 EST

Benjamin Herrenschmidt writes:
> > > Finally I tried using g5_defconfig with 2.6.39-rc3. First boot
> > > it did get to /sbin/init, but udev init took much longer than
> > > normal and threw errors. After a warm reboot the same kernel
> > > hung as usual, this time before framebuffer init.
> > >
> > > 2.6.38 works just fine.
> >
> > Hrm, that must be new, I remember testing something around -rc1 on a
> > similar machine and it worked fine. I'll see if I can find something
> > out.
> Ok so on a PowerMac7,3 here (dual 2.5Ghz and mostly same HW or at least
> very similar) I can't reproduce your problem with a g5_defconfig.
> Your config doesn't work well for me (I don't do modules, I netboot),
> but after adding a few things to it, it seems to work fine as well. I
> added radeonfb and the radeon DRM (not KMS) and I added eventfd, timerfd
> and input events.
> So I'm afraid I'm going to need you to bisect that one to find out what
> exact change caused the breakage for you.

Thanks for checking. I'll try a bisect later today.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at