Re: [PATCH V8 4/8] mm/fs: add hooks to support cleancache

From: Andrew Morton
Date: Fri Apr 15 2011 - 11:09:20 EST

On Fri, 15 Apr 2011 07:47:57 -0700 (PDT) Dan Magenheimer <dan.magenheimer@xxxxxxxxxx> wrote:

> Hi Minchan --
> > First of all, thanks for resolving conflict with my patch.
> You're welcome! As I pointed out offlist, yours was the first
> change in MM that caused any semantic changes to the cleancache
> core hooks patch since before 2.6.18.
> > Before I suggested a thing about cleancache_flush_page,
> > cleancache_flush_inode.
> >
> > what's the meaning of flush's semantic?
> > I thought it means invalidation.
> > AFAIC, how about change flush with invalidate?
> I'm not sure the words "flush" and "invalidate" are defined
> precisely or used consistently everywhere in computer
> science, but I think that "invalidate" is to destroy
> a "pointer" to some data, but not necessarily destroy the
> data itself. And "flush" means to actually remove
> the data. So one would "invalidate a mapping" but one
> would "flush a cache".
> Since cleancache_flush_page and cleancache_flush_inode
> semantically remove data from cleancache, I think flush
> is a better name than invalidate.
> Does that make sense?

nope ;)

Kernel code freely uses "flush" to refer to both invalidation and to
writeback, sometimes in confusing ways. In this case,
cleancache_flush_inode and cleancache_flush_page rather sound like they
might write those things to backing store.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at