RE: [PATCH V8 4/8] mm/fs: add hooks to support cleancache
From: Dan Magenheimer
Date: Fri Apr 15 2011 - 11:34:32 EST
> From: Andrew Morton [mailto:akpm@xxxxxxxxxxxxxxxxxxxx]
> On Fri, 15 Apr 2011 07:47:57 -0700 (PDT) Dan Magenheimer
> <dan.magenheimer@xxxxxxxxxx> wrote:
> > Hi Minchan --
> > > Before I suggested a thing about cleancache_flush_page,
> > > cleancache_flush_inode.
> > >
> > > what's the meaning of flush's semantic?
> > > I thought it means invalidation.
> > > AFAIC, how about change flush with invalidate?
> > I'm not sure the words "flush" and "invalidate" are defined
> > precisely or used consistently everywhere in computer
> > science, but I think that "invalidate" is to destroy
> > a "pointer" to some data, but not necessarily destroy the
> > data itself. And "flush" means to actually remove
> > the data. So one would "invalidate a mapping" but one
> > would "flush a cache".
> > Since cleancache_flush_page and cleancache_flush_inode
> > semantically remove data from cleancache, I think flush
> > is a better name than invalidate.
> > Does that make sense?
> nope ;)
> Kernel code freely uses "flush" to refer to both invalidation and to
> writeback, sometimes in confusing ways. In this case,
> cleancache_flush_inode and cleancache_flush_page rather sound like they
> might write those things to backing store.
OK, I guess I am displaying my kernel-newbie-ness... though,
in this case, writeback of a cleancache page to backing store
doesn't make much sense either (since cleancache pages are
by definition "clean").
I'm happy to rename the hooks, though will probably not
repost a V9 unless/until more substantive changes collect...
unless someone considers this an unmergeable offense.
Thanks for the feedback, Minchan and Andrew!
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/