Re: [PATCH 6/8] staging: vme: rename *_slot_get to *_get_slot

From: Greg KH
Date: Tue Aug 09 2011 - 11:55:30 EST

On Tue, Aug 09, 2011 at 04:18:24PM +0100, Martyn Welch wrote:
> On 01/08/11 13:31, Manohar Vanga wrote:
> > Hi Martyn,
> >
> >> If your doing vme_slot_get, then there's also vme_lm_get, vme_master_get and
> >> vme_slave_get.
> >>
> >> Doing just this would then lead to more inconsistency in the naming and
> >> wouldn't even get rid of all the functions using the *_get naming convention.
> >
> > I can simply change those as well and resend :)
> >
> >> I'm not sure this change is worth it.
> >
> > I thought it would be worth changing this especially with the addition of bridge
> > refcounting functions (which have the *_get/_set convention).
> >
> The naming of the API is reasonably consistent at the moment. It looks like we
> aren't going to need to export vme_bus_get and vme_bus_put based on the
> conversation on patch 5. In addition to this, I've discovered that the
> functions for USB are actually called usb_get_dev and usb_put_dev, so the
> *_put/get convention isn't very strictly adhered to. I'd prefer to keep the
> API as is.

It's not that strict, so I wouldn't worry about changing the names, as
it's obvious what is happening.

greg k-h
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at