Re: [PATCH 07/10] ktest: Introduce PASS_COUNT

From: Andrew Jones
Date: Fri Aug 12 2011 - 13:10:14 EST

On Fri, Aug 12, 2011 at 12:49:45PM -0400, Steven Rostedt wrote:
> On Fri, 2011-08-12 at 15:32 +0200, Andrew Jones wrote:
> > Add another config variable that defines the number of times a test
> > must pass before it really passes. This is good for boot tests, where
> > the failure doesn't occur every time.
> I'm curious to how this is really different than the ITERATE keyword.
> That is, if we had:
> TEST_TYPE = test
> TEST = ssh root@box "/work/runtest"
> Hmm, is this to help in the bisects?

Right. I played with ITERATE, but it didn't look like it would work
for bisecting boot problems that may fail once in some number of
boots. Perhaps I missed something though.

> Maybe it should be called ITERATE as well, just to be consistent.
> TEST_TYPE = bisect
> ITERATE = 10
> ??
> Or maybe that is confusing too, as that could be used to do the iterate
> within the TEST_START (hmm, I may add that).
> How about PASS_THRESHOLD? or PASS_COUNT_THRESHOLD? As I think that may
> be more descriptive.

PASS_THRESHOLD sounds good. Should I respin with that change now? Or are
you still considering a different design?

> /me rereads his email and sees that he has a tendency to talk to
> himself.

/me wonders if he answered himself with a different design idea, so will
hold off on the updated patch for the moment.

> -- Steve
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at