Problem compiling firmware/yam/9600.bin in 3.8.8

From: Stephan von Krawczynski
Date: Thu Apr 25 2013 - 09:48:22 EST

Hello all,

I just tried to compile a complete kernel 3.8.8 including firmwares. First I
linked /usr/include/linux to /usr/src/linux/include/linux. I think this is for
user-space compilations to use the right header files, correct?
Then I tried the kernel and this is what happened:

IHEX firmware/yam/9600.bin
In file included from /usr/include/bits/errno.h:24:0,
from /usr/include/errno.h:35,
from firmware/ihex2fw.c:15:
/usr/include/linux/errno.h:4:30: fatal error: uapi/linux/errno.h: No such file
or directory compilation terminated.
make[1]: *** [firmware/ihex2fw] Error 1
make: *** [modules] Error 2

/usr/include/uapi is empty, but
/usr/src/linux/include/uapi is not

Did I miss something or are there more links to make nowadays for a complete setup?

Please cc me in case ...

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at