Re: [PATCH v2 net-next] net: filter: rename 'struct sk_filter' to 'struct bpf_prog'
From: Pablo Neira Ayuso
Date: Sat Jul 26 2014 - 06:18:56 EST
On Fri, Jul 25, 2014 at 12:11:09PM -0700, Alexei Starovoitov wrote:
> 'sk_filter' name is used as 'struct sk_filter', function sk_filter() and
> as variable 'sk_filter', which makes code hard to read.
> Also it's easily confused with 'struct sock_filter'
> Rename 'struct sk_filter' to 'struct bpf_prog' to clarify semantics and
> align the name with generic BPF use model.
> The only ugly place is uapi/linux/netfilter/xt_bpf.h which
> managed to expose kernel internal structure into uapi header.
> So replace 'struct sk_filter *' there with 'void *' and type cast it
> to 'struct bpf_prog *' inside kernel in net/netfilter/xt_bpf.c
> Signed-off-by: Alexei Starovoitov <ast@xxxxxxxxxxxx>
> replace 'struct sk_filter *' with 'void *' in uapi/../xt_bpf.h
> (seems Daniel and Willem prefere this option)
Please, we're still discussing this in the original thread:
And don't trim me off from the CC. Thanks.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/