Re: [PATCH v2] vfs: Don't exchange "short" filenames unconditionally.

From: Al Viro
Date: Mon Sep 29 2014 - 15:04:29 EST

On Mon, Sep 29, 2014 at 10:54:59AM -0700, Linus Torvalds wrote:
> On Mon, Sep 29, 2014 at 9:27 AM, Al Viro <viro@xxxxxxxxxxxxxxxxxx> wrote:
> >
> > What we get in free_dentry() is:
> > * external name not shared: refcount driven to 0, RCU-delayed
> > call of "free dentry, free ext name"
> > * external name still shared: refcount positive after decrement,
> > no freeing ext name
> > * no external name: no ext name to free
> > In the last two cases we do what dentry_free() used to do, except that now
> > __d_free() doesn't even look for ext name. Just frees the dentry. If
> > it never had been hashed - directly called, otherwise - via call_rcu().
> >
> > Does that look OK for you?
> Yes. That looks fairly straightforward.
> Although please rename that "ext" in ext_name/__d_free_ext() to
> something else. "ext" to me says not "external", but "extended". I
> think we can just write out "external", like we already do in
> "dname_external()".

That we do... Why is it in dcache.h, BTW? No users outside of fs/dcache.c
and I can't imagine a valid use for it in a module, let alone out-of-tree

ObAnnoyance: gcc not figuring out that this container_of() isn't going to be
NULL... Sure, somebody might put (char *)16 into dentry->, but...
As it is, it makes for messier code generation; I can work around that, of
course, but it's uglier than it ought to be ;-/

OK, see vfs.git#copy_name. Warning: it does need testing. Two commits in
there, one adding data dependency barrier in prepend_name(), another - this
thing. Comments would be welcome...
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at