Re: [PATCH V2 4/4] hugetlbfs: document min_size mount option

From: Mike Kravetz
Date: Fri Mar 20 2015 - 12:24:41 EST

On 03/18/2015 07:23 PM, Andrew Morton wrote:
On Wed, 18 Mar 2015 18:51:22 -0700 Mike Kravetz <mike.kravetz@xxxxxxxxxx> wrote:

Nowhere here is the reader told the units of "size". We should at
least describe that, and maybe even rename the thing to min_bytes.

Ok, I will add that the size is in unit of bytes. My choice of
'min_size' as a name for the new mount option was influenced by
the existing 'size' mount option. I'm open to any suggestions
for the name of this new mount option.

Yes, due to the preexisting "size" I think we're stuck with "min_size".
We could use min_size_bytes I guess, but the operator needs to go look
up the units of "size" anyway.

Well, the existing size option can also be specified as a percentage of
the huge page pool size. This is in the current code. There is a
mount option 'pagesize=' that allows one to select which huge page
(size) pool should be used. If none is specified the default huge page
pool is used. There is no documentation for this pagesize option or
using size to specify a percentage of the huge page pool size.

I'll add this to the hugetlbpage.txt documentation.
Mike Kravetz
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at