Re: [PATCH v2 1/5] KVM: add kvm_has_request wrapper

From: Radim KrÄmÃÅ
Date: Thu Aug 13 2015 - 05:11:24 EST

2015-08-12 21:57+0200, Christian Borntraeger:
> kvm_check_request is now somewhat a misnomer (what is the difference between test and check?)

kvm_check_request has always been poetic; it uses two meanings of
check, "examine" and "tick off", at the same time.

We also want something that clears the request, so kvm_drop_request was
my best candidate so far.

> for the new interface. maybe we can rename kvm_check_request in a separate patch somewhen.

I wonder why haven't we copied the naming convention from bit operations
(or if programming would be better if German was its language),


The only disadvantage is that
is longer than
by whooping 9 characters.

I could live with that.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at