Re: [PATCH 03/11] perf tools: Do not change lib/api/fs/debugfs directly

From: Arnaldo Carvalho de Melo
Date: Wed Aug 26 2015 - 10:44:08 EST


Em Wed, Aug 26, 2015 at 10:06:45AM -0400, Raphaël Beamonte escreveu:
> On Aug 26, 2015 9:47 AM, "Jiri Olsa" <jolsa@xxxxxxxxxx> wrote:
> >
> > The tracing_events_path is the variable we want to change
> > via --debugfs-dir option, not the debugfs_mountpoint.
>
> <SNIP>
>
> > perf_debugfs_set_path(cmd +
> strlen(CMD_DEBUGFS_DIR));
> > - fprintf(stderr, "dir: %s\n", debugfs_mountpoint);
> > + fprintf(stderr, "dir: %s\n", tracing_path);
> > if (envchanged)
> > *envchanged = 1;
> > } else if (!strcmp(cmd, "--list-cmds")) {
> > diff --git a/tools/perf/util/util.c b/tools/perf/util/util.c
> > index d33c34196a5a..7acafb3c5592 100644
> > --- a/tools/perf/util/util.c
> > +++ b/tools/perf/util/util.c
> > @@ -439,7 +439,6 @@ const char *perf_debugfs_mount(const char *mountpoint)
> >
> > void perf_debugfs_set_path(const char *mntpt)
> > {
> > - snprintf(debugfs_mountpoint, strlen(debugfs_mountpoint), "%s",
> mntpt);
> > set_tracing_events_path("tracing/", mntpt) ;
> > }
>
> Why keep a function name with debugfs in it here if we're not touching
> debugfs anymore?

Right

> Shouldn't we call directly set_tracing_events_path if that's what we
> want to do? Also, the option name --debugfs-dir is not entirely
> relevant anymore?

Yeah, probably that was a really bad name to start with, i.e. it
should've been named perhaps --event-definitions-dir or something to
that degree.

"debugfs", "tracefs" and the next thing to come in this area are just
implementation details :-)

- Arnaldo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/