Re: [PATCH v4 0/3] checkpatch: handling of memory barriers

From: Michael S. Tsirkin
Date: Mon Jan 11 2016 - 06:04:40 EST


On Mon, Jan 11, 2016 at 12:59:25PM +0200, Michael S. Tsirkin wrote:
> As part of memory barrier cleanup, this patchset
> extends checkpatch to make it easier to stop
> incorrect memory barrier usage.
>
> This replaces the checkpatch patches in my series
> arch: barrier cleanup + barriers for virt
> and will be included in the pull request including
> the series.
>
> changes from v3:
> rename smp_barrier_stems to barrier_stems
> as suggested by Julian Calaby.

In fact it was Joe Perches that suggested it.
Sorry about the confusion.

> add (?: ... ) around a variable in regexp,
> in case we change the value later so that it matters.
> changes from v2:
> address comments by Joe Perches:
> use (?: ... ) to avoid unnecessary capture groups
> rename smp_barriers to smp_barrier_stems for clarity
> add barriers before/after atomic
> Changes from v1:
> catch optional\s* before () in barriers
> rewrite using qr{} instead of map
>
> Michael S. Tsirkin (3):
> checkpatch.pl: add missing memory barriers
> checkpatch: check for __smp outside barrier.h
> checkpatch: add virt barriers
>
> Michael S. Tsirkin (3):
> checkpatch.pl: add missing memory barriers
> checkpatch: check for __smp outside barrier.h
> checkpatch: add virt barriers
>
> scripts/checkpatch.pl | 33 ++++++++++++++++++++++++++++++++-
> 1 file changed, 32 insertions(+), 1 deletion(-)
>
> --
> MST