Re: [PATCH 00/11] sync framework de-staging: part 1 - clean up

From: Maarten Lankhorst
Date: Mon Jan 25 2016 - 06:24:07 EST


Op 21-01-16 om 13:49 schreef Gustavo Padovan:
> From: Gustavo Padovan <gustavo.padovan@xxxxxxxxxxxxxxx>
> Hi,
> The following patches are some clean ups on the sync framework before
> we start the actual de-staging. The main changes here are the move of
> SW_SYNC_USER to debugfs. Removal of struct sync_pt in favor of direct
> use of struct fence. And the rename of sync_fence to sync_file, a name
> to better reflect what it is for, a struct that connects struct fence(s)
> to a file.
> Please review. Thanks.
> Gustavo Padovan (11):
> staging/android: fix sync framework documentation
> staging/android: sync: remove interfaces that are not used
> staging/android: remove not used sync_timeline ops
> staging/android: create a 'sync' dir for debugfs information
> staging/android: move SW_SYNC_USER to a debugfs file
> staging/android: rename sync_fence to sync_file
> staging/android: rename 'sync_pt' to 'fence' in struct sync_fence_cb
> staging/android: remove struct sync_pt
> staging/android: remove unused var from sync_timeline_signal()
> staging/android: remove pointless sync_timeline_signal at destroy
> phase
> staging/android: remove sync_fence_create_dma()
For whole series:
Reviewed-by: Maarten Lankhorst <maarten.lankhorst@xxxxxxxxxxxxxxx>

Renaming sync_fence to sync_file makes sense, it should hopefully reduce confusion.