Re: [PATCH 2/3] x86/mce/AMD, EDAC: Simplify SMCA decoding

From: Borislav Petkov
Date: Wed Mar 02 2016 - 11:21:50 EST


On Wed, Mar 02, 2016 at 09:52:23AM -0600, Aravind Gopalakrishnan wrote:
> So, I think we should continue this approach and have something like this-
> static const char * const amd_core_mcablock_names[] = {
> [SMCA_LS] = "load_store",
> [SMCA_IF] = "insn_fetch",
> [SMCA_L2_CACHE] = "l2_cache",
> [SMCA_DE] = "decode_unit",
> [RES] = "",
> [SMCA_EX] = "execution_unit",
> [SMCA_FP] = "floating_point",
> [SMCA_L3_CACHE] = "l3_cache",
> };
>
> static const char * const amd_df_mcablock_names[] = {
> [SMCA_CS] = "coherent_slave",
> [SMCA_PIE] = "pie",
> };
>
> (Split arrays again because I feel it'd be better to have arrays ordered
> according to mca_type values)

Ok, care to take the patch and redo it as you suggest?

I really don't want to be assigning strings each time during decoding.

Also, make sure the strings are as human readable as possible and so
that users can at least have an idea what we're saying. "load_store"
is better than "LS", "insn_fetch" is better than "IF", etc. Some
abbreviations should remain, though. "platform_security_processor" is
yucky and I guess there we can stick to "PSP". Ditto for "SMU"...

Making the unabbreviated lowercase for sysfs usage is fine too, of
course.

Thanks.

--
Regards/Gruss,
Boris.

ECO tip #101: Trim your mails when you reply.