Re: [PATCH v7 1/4] gadget: Introduce the usb charger framework
From: Felipe Balbi
Date: Thu Mar 31 2016 - 02:23:58 EST
Mark Brown <broonie@xxxxxxxxxx> writes:
> [ text/plain ]
> On Wed, Mar 30, 2016 at 01:09:00PM +0300, Felipe Balbi wrote:
>> Baolin Wang <baolin.wang@xxxxxxxxxx> writes:
>> > +#include <linux/of.h>
>> > +#include <linux/of_device.h>
>> > +#include <linux/of_address.h>
>> > +#include <linux/platform_device.h>
>> not very nice to depend on either of or platform_device here. What about
>> PCI-based devices ?
> The header inclusion shouldn't be conditional though. But looking at
> the patch I can't immediately see any use of these in the code anyway.
fair enough, seems like removal is the way.
>> > +static DEVICE_ATTR_RW(sdp_limit);
>> why RW ? Who's going to use these ? Also, you're not documenting this
>> new sysfs file.
> If they end up not writeable should we just remove them entirely since
> they should just be the spec values?
if they are really just spec values, why would even let them be modified
to start with ? ;-)
But yeah, seems like this is not interesting to userland.
Description: PGP signature