Re: [PATCH] mm, slab: rename kmalloc-node cache to kmalloc-<size>

From: Matthew Wilcox
Date: Mon Feb 06 2017 - 09:52:49 EST


On Fri, Feb 03, 2017 at 07:10:08PM +0100, Vlastimil Babka wrote:
> diff --git a/mm/slab.c b/mm/slab.c
> index a95fd4fed0a8..ede31b59bb9f 100644
> --- a/mm/slab.c
> +++ b/mm/slab.c
> @@ -1293,7 +1293,8 @@ void __init kmem_cache_init(void)
> * Initialize the caches that provide memory for the kmem_cache_node
> * structures first. Without this, further allocations will bug.
> */
> - kmalloc_caches[INDEX_NODE] = create_kmalloc_cache("kmalloc-node",
> + kmalloc_caches[INDEX_NODE] = create_kmalloc_cache(
> + get_kmalloc_cache_name(INDEX_NODE),

Could we lose the 'get_' from the front? I think 'kmalloc_cache_name()' is
just as informative.

Reviewed-by: Matthew Wilcox <mawilcox@xxxxxxxxxxxxx>