Re: [PATCH v2 11/13] perf header: change FEAT_OP* macros

From: Jiri Olsa
Date: Thu May 25 2017 - 04:09:46 EST


On Tue, May 23, 2017 at 12:48:51AM -0700, David Carrillo-Cisneros wrote:

SNIP

> -#define FEAT_OPA(n, func) \
> - [n] = { .name = #n, .write = write_##func, .print = print_##func }
> -#define FEAT_OPP(n, func) \
> - [n] = { .name = #n, .write = write_##func, .print = print_##func, \
> - .process = process_##func }
> -#define FEAT_OPF(n, func) \
> - [n] = { .name = #n, .write = write_##func, .print = print_##func, \
> - .process = process_##func, .full_only = true }
> +#define FEAT_OPR(n, func, __full_only) \
> + [HEADER_##n] = { \
> + .name = __stringify(HEADER_##n), \
> + .write = write_##func, \
> + .print = print_##func, \
> + .full_only = __full_only, \
> + .process = process_##func, \
> + .has_record = true \
> + }
> +
> +#define FEAT_OPN(n, func, __full_only) \
> + [HEADER_##n] = { \
> + .name = __stringify(HEADER_##n), \
> + .write = write_##func, \
> + .print = print_##func, \
> + .full_only = __full_only, \
> + .process = process_##func \
> + }

could you please align this (and in other places of the patchset), like:

.name = __stringify(HEADER_##n), \
.write = write_##func, \
.print = print_##func, \
.full_only = __full_only, \
.process = process_##func \

much more readable..

thanks,
jirka