On Wed, Aug 16, 2017 at 12:45 PM, Scott BrandenWe have some cleanup work to do. Need to move to mfd and address your comments.
<scott.branden@xxxxxxxxxxxx> wrote:
From: Shreesha Rajashekar <shreesha@xxxxxxxxxxxx>How is this an MFD? Should be bindings/w1/...
Adding document for IPROC d1w driver.
Signed-off-by: Shreesha Rajashekar <shreesha@xxxxxxxxxxxx>
Signed-off-by: Scott Branden <scott.branden@xxxxxxxxxxxx>
---
.../devicetree/bindings/mfd/brcm,iproc-d1w.txt | 27 ++++++++++++++++++++++
1 file changed, 27 insertions(+)
create mode 100644 Documentation/devicetree/bindings/mfd/brcm,iproc-d1w.txt
diff --git a/Documentation/devicetree/bindings/mfd/brcm,iproc-d1w.txt b/Documentation/devicetree/bindings/mfd/brcm,iproc-d1w.txtThis should be bus-frequency. We messed up on I2C.
new file mode 100644
index 0000000..2bb99c1
--- /dev/null
+++ b/Documentation/devicetree/bindings/mfd/brcm,iproc-d1w.txt
@@ -0,0 +1,27 @@
+* Broadcom Dallas One wire (D1W) bus master controller
+
+Required properties:
+- compatible : should be "brcm,iproc-d1w"
+- reg : Address and length of the register set for the device
+- interrupts : IRQ number of D1W controller
+
+Optional properties:
+- clocks : phandle of clock that supplies the module (required if platform
+ clock bindings use device tree)
+- clock-names : name for the clock
+- clock-frequency : D1W divisor clock rate
+- reset-recover-delay : Delay while reset D1W in milliseconds.Is this a standard 1-wire bus operation? I'm guessing so, but if not
needs a vendor prefix.
Also, needs unit suffix as defined in property-units.txt.
+Should be a generic name. So far in bindings/w1/ we have 3 different
+Example:
+
+- From bcm-cygnus.dtsi:
+iproc_d1w: d1w@180ab000 {
ones in 3 bindings. Lets go with "onewire".
+ compatible = "brcm,iproc_d1w";Doesn't match the doc.
+ reg = <0x180ab000 0x0f>;
+ interrupts = <GIC_SPI 150 IRQ_TYPE_LEVEL_HIGH>;
+ clocks = <&axi81_clk>;
+ clock-names = "iproc_d1w_clk";
+ clock-frequency = <100000000>;
+ reset-recover-delay = <1>;
+};
+
--
2.5.0