Re: [PATCH 1/1] nvme: implement log page low/high offset and dwords

From: Matias BjÃrling
Date: Tue Feb 13 2018 - 08:53:09 EST


On 02/13/2018 02:47 PM, Johannes Thumshirn wrote:
On Tue, 2018-02-13 at 13:49 +0100, Matias BjÃrling wrote:
+int nvme_get_log_ext(struct nvme_ctrl *ctrl, struct nvme_ns *ns,
+ ÂÂÂÂu8 log_page, void *log,
+ ÂÂÂÂsize_t size, size_t offset)
+{
+ struct nvme_command c = { };
+ unsigned long dwlen = (size / 4) - 1;

Consulting my long gone maths knowledge suggests the parantheses aren't
really needed here.


Heh, you're right. However, it does make it a bit more readable? The untrained eye would properly mess it up was my thinking for keeping them.