Re: [PATCH v11 11/13] intel_sgx: ptrace() support

From: Sean Christopherson
Date: Mon Jun 11 2018 - 11:02:16 EST


On Fri, 2018-06-08 at 11:34 -0700, Dave Hansen wrote:
> On 06/08/2018 10:09 AM, Jarkko Sakkinen wrote:
> >
> > + ret = sgx_edbgrd(encl, entry, align, data);
> > + if (ret)
> > + break;
> > + if (write) {
> > + memcpy(data + offset, buf + i, cnt);
> > + ret = sgx_edbgwr(encl, entry, align, data);
> > + if (ret)
> > + break;
> > + }
> > + else
> > + memcpy(buf + i,data + offset, cnt);
> > + }
> The SGX instructions like "edbgrd" be great to put on a license plat,
> but we can do better in the kernel.ÂÂCan you give these reasonable
> english names, please?ÂÂsgx_debug_write(), maybe?

IMO the function names for ENCLS leafs are appropriate. ÂThe real
issue is the lack of documentation of the ENCLS helpers and their
naming conventions.

The sgx_<leaf> functions, e.g. sgx_edbgrd(), are essentiallyÂdirect
invocations of the specific leaf, i.e. they are dumb wrappers to
the lower level leaf functions, e.g. __edbgrd(). ÂThe wrappers exist
primarily to deal with the boilerplate necessary to access a page in
the EPC. Âsgx_<leaf> conveys that the function contains the preamble
and/or postamble needed to execute its leaf, but otherwise does not
contain any logic.

Functions with actual logic do have English names, e.g.
sgx_encl_init(), sgx_encl_add_page(),Âsgx_encl_modify_pages() etc...

> Note that we have plenty of incomprehensible instruction names in the
> kernel like "wrpkru", but we do our best to keep them as confined as
> possible and make sure they don't hurt code readability.