Re: [PATCH v3 2/3] i2c: i2c-qcom-geni: Simplify tx/rx functions

From: Doug Anderson
Date: Tue Sep 25 2018 - 17:49:52 EST


Hi,

On Mon, Sep 24, 2018 at 4:52 PM Stephen Boyd <swboyd@xxxxxxxxxxxx> wrote:
>
> We never really look at the 'ret' local variable in these functions, so
> let's remove it to make way for shorter and simpler code. Furthermore,
> we can shorten some lines by adding two local variables for the SE and
> the message length so that everything fits in 80 columns and testing the
> 'dma_buf' local variable in lieu of the 'mode' local variable. And
> kernel style is to leave the return statement by itself, detached from
> the rest of the function.
>
> Cc: Karthikeyan Ramasubramanian <kramasub@xxxxxxxxxxxxxx>
> Cc: Sagar Dharia <sdharia@xxxxxxxxxxxxxx>
> Cc: Girish Mahadevan <girishm@xxxxxxxxxxxxxx>
> Cc: Doug Anderson <dianders@xxxxxxxxxxxx>
> Signed-off-by: Stephen Boyd <swboyd@xxxxxxxxxxxx>
> ---
> drivers/i2c/busses/i2c-qcom-geni.c | 79 ++++++++++++++----------------
> 1 file changed, 36 insertions(+), 43 deletions(-)

It's so polished I can see my reflection in it now. Looks like this
snuck in a few other cleanups compared to v2 (move "gi2c->cur = ..."
to be common between tx/rx and removed a pointless init of time_left).
Seems good. In total 7 lines shorter and easier to read.

Reviewed-by: Douglas Anderson <dianders@xxxxxxxxxxxx>